Messages not syncing to Microsoft Teams Shared channels
Identified·Partial outage

Our team is continuously attempting to escalate this with Microsoft but are not making progress as quickly as we would like.

We are continuing to pursue this path but we also started work last week on an alternative flow using Microsoft service accounts to try to unblock this as quickly as possible. We are aiming to have the first version of this new flow available by Thursday Jan 29, possibly as early as Wednesday Jan 28.

If you are interested in helping us test our new workaround flow, please work with your IT team to provision a service account in your Microsoft Teams workspace, add it to your shared channels, and reach out to Pylon support for next steps.

We understand the impact that this may have on your operations and are diligently working towards a solution within the new Microsoft constraints. Please reach out to Pylon support with any questions.

Tue, Jan 27, 2026, 10:59 PM
(2 days ago)
·
Affected components
Integrations
Updates

Identified

Our team is continuously attempting to escalate this with Microsoft but are not making progress as quickly as we would like.

We are continuing to pursue this path but we also started work last week on an alternative flow using Microsoft service accounts to try to unblock this as quickly as possible. We are aiming to have the first version of this new flow available by Thursday Jan 29, possibly as early as Wednesday Jan 28.

If you are interested in helping us test our new workaround flow, please work with your IT team to provision a service account in your Microsoft Teams workspace, add it to your shared channels, and reach out to Pylon support for next steps.

We understand the impact that this may have on your operations and are diligently working towards a solution within the new Microsoft constraints. Please reach out to Pylon support with any questions.

Tue, Jan 27, 2026, 10:59 PM

Identified

Our team has identified a breaking change to bot permissions made by Microsoft which prevents bot messages from sending to Shared and Private Microsoft Teams channels. This change was rolled out without notice and is causing messages sent from Pylon or Slack to not sync to those channels in Teams. Messages sent within the Teams Shared and Private channels are still syncing to Pylon.


For the time being, the recommended workaround would be for members of your organization to respond directly in the Microsoft Teams channel.


Our integrations team is working with Microsoft on a path forward to restore this functionality as soon as possible. Please reach out to Pylon Support with any further questions.

Sat, Jan 17, 2026, 02:35 AM(1 week earlier)

Identified

We are currently experiencing an issue where messages are unable to be sent to Microsoft Teams shared channels. Standard Teams channels and group chats remain unaffected.


Our investigation indicates this issue stems from a change on Microsoft's side - no changes were made to our code or configuration prior to the incident. We have opened a support case with Microsoft and escalated to expedite resolution.


Unfortunately, there is no workaround available at this time, as shared channels are fully impacted. We will provide updates as we learn more from Microsoft, we apologize for any impact this is having on your operations.

Wed, Jan 14, 2026, 06:18 PM(2 days earlier)

Investigating

Our engineering team is investigating an issue causing messages sent from Pylon to not sync to Microsoft Teams Shared channels. Messages sent to Standard Microsoft Teams channels are syncing correctly. We will post updates here as soon as we have more information. We apologize for any impact this is having on your operations, please reach out to Pylon support with any questions.

Tue, Jan 13, 2026, 09:19 PM(20 hours earlier)