Resolved
The issue has been resolved and all systems are operational.
Monitoring
Our upstream provider identified the issue and deployed a fix. We will continue to monitor.
Investigating
We are aware of an issue impacting US customer inbound email delays and are actively tracking. Our upstream vendor posted on their status page here.
https://status.postmarkapp.com/notices/0rctfahtwuovx3ie-webhook-delays