Resolved
The issue has been resolved and all systems are operational- thank you for your pateince and we apologize for any disruption to your workflows.
Monitoring
Our engineers have implemented a fix and are monitoring our systems.
Identified
We have identified the underlying cause of the latency on the API and are working on a fix.
Investigating
We are aware of an issue affecting some latency with API calls and are actively investigating.