Resolved
The underlying issue has been resolved and analytics data has been fully backfilled. We appreciate your patience while we worked to resolve this, please reach out to Pylon support with any questions.
Monitoring
We have implemented a fix and are monitoring as the data is being updated.
Identified
We have identified the underlying cause of the delayed analytics issue and are working on a fix.
Investigating
We are aware of an issue affecting Analytics Dashboards delays and are actively investigating.